#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\s*;.*(?:\R|$)"
Local $sString = "bar" & @CRLF & _
"; Foo" & @CRLF & _
"baz" & @CRLF & _
";Bar" & @CRLF & _
"; aaa aaaaa" & @CRLF & _
"Baz"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)