$re = '/^\s*;.*(?:\R|$)/m';
$str = 'bar
;       Foo
baz
;Bar
;  aaa   aaaaa
Baz';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;