re = /^\s*;.*(?:\R|$)/m
str = 'bar
; Foo
baz
;Bar
; aaa aaaaa
Baz'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result