re = /(?<=click=)([^&]+)/m
str = 'https://play.google.com/store/apps/details?id=air.com.littlebigplay.games.premium.plurals&click=541255b82bc957475c7b6222d1a980a5&mysuffix={HELLO_WORLD}&optid=541255b82bc957475c7b'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end