$re = '/^[\.a-zA-Z0-9_-]([\.a-zA-Z0-9_-]+)*$/m';
$str = 'aaaaaaaaaaaaaaaa!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);