use strict;
my $str = 'hello99____
abcd
_a_b_c_d
_a_b_c_d_
_a_b_c_d_e
____abcd
abcd____
___h8
bcd____
____a
';
my $regex = qr/^(?:_*[A-Za-z0-9]_*){4,}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}