// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:_*[A-Za-z0-9]_*){4,}$").unwrap();
let string = "hello99____
abcd
_a_b_c_d
_a_b_c_d_
_a_b_c_d_e
____abcd
abcd____
___h8
bcd____
____a
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}