using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"int+\s*[a-zA-Z]+\s*\(\s*+[a-zA-Z]+\s*(,+\s*+[a-zA-Z]+\s*)*\)";
string input = @"int sum ( int , int)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}