package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)int+\s*[a-zA-Z]+\s*\(\s*+[a-zA-Z]+\s*(,+\s*+[a-zA-Z]+\s*)*\)`)
var str = `int sum ( int , int)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}