#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<(\/?)(html|head|body)[>\s]([^>]*)>?"
Local $sString = "<header class="">" & @CRLF & _
"<header>" & @CRLF & _
"<head class=">" & @CRLF & _
"<head>" & @CRLF & _
"<head><div>" & @CRLF & _
"<head ><div>" & @CRLF & _
"<head > <div>" & @CRLF & _
"<head ><!--"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")