using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\/?)(html|head|body)[>\s]([^>]*)>?";
string input = @"<header class="">
<header>
<head class="">
<head>
<head><div>
<head ><div>
<head > <div>
<head ><!--";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}