import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z0-9\\._%+-]+(\\s*@\\s*|\\s*[\\[|\\{|\\(]+\\s*(at|@)\\s*[\\)|\\}\\]]+\\s*)([A-Z0-9\\.-]+(\\.|\\s*[\\[|\\{|\\(]+\\s*(dot|\\.)\\s*[\\)|\\}|\\]]+\\s*))+[a-z]{2,6}";
final String string = "Hello hi_there@gmail.com, welcome to Gskinner!\n"
+ "Hello hi_there [at] gmail [dot] com, welcome to Gskinner!\n"
+ "Hello hi_there (at) gmail (dot) co (dot) uk, welcome to Gskinner!\n"
+ "Hello jam+jim @ googlemail.com, welcome to Gskinner!\n"
+ "Hello heythere {at} guardian [dot] co (dot) uk, welcome to Gskinner!\n"
+ "Hello contact [[[@]]] jazzit (dot) hr, welcome to Gskinner!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}