using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^""]*(?:""[^""]*)*""";
string input = @"""Chiffre"",""Nom"",""Descriptif court"",""Tarifs en clair"",""Période en clair"",""Adresse 1"",""CP"",""Tel"",""""Site"""",""Facebook"",""Pictos"",""@Saveurs"",""@Famille plus"",""@Img"",""Accessible en fauteuil roulant en autonomie"",""Handicapes"",""Terrasse"",""Wifi"",""Chèque Vacances"",""Titre Restaurant""
6,""Le Chalet d'en Ô"",""Cuisine traditionnelle (foie gras, magret myrtilles, croustillant chocolat)
Spécialités savoyardes (fondue, tartiflette.. )
Garanti sans burgers.
Tout est fait maison.Cuisine traditionnelle (foie gras, magret myrtilles, croustillant chocolat)
Spécialités savoyardes (fondue, tartiflette.. )
Garanti sans burgers.
Tout est fait maison."",""Menu adulte : de 20 à 30 €
Menu enfant : 10 €.
Suggestion du jour le midi en semaine : entrée,plat, dessert : 20€.Menu adulte : de 20 à 30 €
Menu enfant : 10 €.
Suggestion du jour le midi en semaine : entrée,plat, dessert : 20€."",""Midi et soir du jeudi au samedi + midi le dimanche et jours fériés.
Juillet et août, midi et soir du mardi au samedi et midi uniquement dimanche et jours fériés.Midi et soir du jeudi au samedi + midi le dimanche et jours fériés.
Juillet et août, midi et soir du mardi au samedi et midi uniquement dimanche et jours fériés."",""Le Cropt - Route de Serraval"",""74230 Les Clefs"",""+33 4 50 02 09 00"",""www.lechaletdeno.com"",,""A R J X x"",,,,,""A"",""R"",""J"",""X"",""x""
7,""La Cabane - Pisciculture de Montremont"",""Bar - restaurant au bord de la rivière dans un cadre champêtre avec sa spécialité la truite."",""Menu adulte : de 26 à 35 €."",""Juin et septembre : du mercredi au dimanche.
Juillet et août : tous les jours à midi + mercredi à samedi le soir.Juin et septembre : du mercredi au dimanche.
Juillet et août : tous les jours à midi + mercredi à samedi le soir."",""Pisciculture de Montremont - 100 impasse des Pesetz"",""74230 Thônes"",""+33 4 50 02 00 85"",""pisciculture-montremont.fr"",,""A R X x"",,,,,""A"",""R"",,""X"",""x""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}