re = /.*(\"key\":\"(\w*)\")/
str = 'blalasdl8ujd "key":"value", blblabla asdw "alo":"ebobo",blabla"www":"zzzz"
blalasdl8ujd "key":"value", blblabla asdw "alo":"ebobo",blabla"www":"zzzz"
blalasdl8ujd "key":"value", blblabla asdw "alo":"ebobo",blabla"www":"zzzz"
blalasdl8ujd "key":"value", blblabla asdw "alo":"ebobo",blabla"www":"zzzz"
blalasdl8ujd "key":"value", blblabla asdw "alo":"ebobo",blabla"www":"zzzz"
blalasdl8ujd "key":"value", blblabla asdw "alo":"ebobo",blabla"www":"zzzz","key":"sdsfs",
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end