#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(([A-Z]+)-([0-9]+))\[([A-Z]+)-([A-Z0-9-]+)(\])"
Local $sString = "PSHELF-2[PSHELF-MF-6RU]" & @CRLF & _
"SHELF-5[SHELF-M6]" & @CRLF & _
"SHELF-6[SHELF-M15]" & @CRLF & _
"SHELF-6[SHELF-M15]"
Local $sSubst = "\1 \4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)