$re = '/(([A-Z]+)-([0-9]+))\[([A-Z]+)-([A-Z0-9-]+)(\])/m';
$str = 'PSHELF-2[PSHELF-MF-6RU]
SHELF-5[SHELF-M6]
SHELF-6[SHELF-M15]
SHELF-6[SHELF-M15]';
$subst = "\1 \4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;