const regex = /^[A-Z]{1}[a-z]{2,15}\s[A-Z]{1}[a-z]{2,15}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z]{1}[a-z]{2,15}\\s[A-Z]{1}[a-z]{2,15}$', '')
const str = `Arnel Jose`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}