re = /^(?:(MORE)|LESS) THAN CAD [\d,]+(?(1)(?: BUT LESS THAN CAD [\d,]+)?)$/m
str = 'MORE THAN CAD 10,000
MORE THAN CAD 10,000 BUT LESS THAN CAD 15,000
LESS THAN CAD 10,000
MORE THAN CAD 10,000LESS THAN CAD 15,000
LESS THAN CAD 10,000 BUT LESS THAN CAD 10,000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end