$re = '/^.*\K\bONE\b.*/m';
$str = 'ONE;TWO;THREE;ONE;FOUR;FIVE
2 TEST
3 ONE test
4 TEST
5 TEST
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);