// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?s)(?:new\sMyClass\(new\sAnotherClass\(\).*?\))").unwrap();
let string = "return new MyClass(constructor, options, ...);
# case 1
var mc = new MyClass();
# case 2
var mc = new MyClass(new AnotherClass());
# case 3
var amc = new MyClass(options, new AnotherClass(), ...);
# case 4
MyClass mc = new MyClass(
something
);
# case 5
MyClass mc = new MyClass(
new AnotherClass()
);
# case 6
MyClass mc = new MyClass(
options, new AnotherClass()
);
# case 7
var amc = new MyClass(new AnotherClass(), options, ...);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}