const regex = /^(?=.+[@#$%&*-_\/\.!])(?=.+[a-z])(?=.+[A-Z])(?=.+[0-9])[A-Za-z0-9@#$%&*-_\/\.!]{6,30}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.+[@#$%&*-_\\\/\\.!])(?=.+[a-z])(?=.+[A-Z])(?=.+[0-9])[A-Za-z0-9@#$%&*-_\\\/\\.!]{6,30}$', 'gm')
const str = `A08a^&0azAad
A08a^&0azAadA08a^&0azAadA08a^&0azAad
ad98qrq
Afaq-r9Â
Afaq-r9z&8
Afaqr9z&8A
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}