$re = '/^([A-z_0-9_a-z]+)\.([A-z_0-9_a-z]+)@([a-z]+)\.([a-z]+)\.([a-z]+)$/m';
$str = 'karre.kamal@st.niituniversity.in';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);