$re = '~((?!(jpeg|gif|png|pdf|jpg|css|js|woff|woff2|ttf)).)*$~m';
$str = '/.well-known/acme-challenge/<TOKEN>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);