re = /(0[1-9]|[12][0-9]|3[01])\-(0[1-9]|1[0,1,2])\-(18|19|20)\d{2}/m
str = '31-02-1700'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end