// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(0[1-9]|[12][0-9]|3[01])\-(0[1-9]|1[0,1,2])\-(18|19|20)\d{2}").unwrap();
let string = "31-02-1700";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}