use strict;
my $str = 'M1 5AA
M12 5AA
BL1 5AA
BL12 5AA
M1K 5AA
BL1K 5AA
';
my $regex = qr/^((BL[0-9]{1,2})|((BL[0-9][A-Z])|((M[0-9]{1,2})|((M[0-9][A-Z])|((OL[0-9]{1,2})|((OL[0-9][A-Z])|((SK[0-9]{1,2})|((SK[0-9][A-Z])|((WA[0-9]{1,2})|((WA[0-9][A-Z])|((WN[0-9]{1,2}|((WN[0-9][A-Z])))))))))))))) [0-9][A-Z]{2}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}