package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+.)+ (\w)`)
var str = `1.43.7.112. Teste.
26.0.177. Teste.
1.1.1.1.1. Teste. Teste1.
1.1.1.1. Teste
1. Teste
1.43.7.112. Teste. 1.43.7.112. Teste.
1.43.7.112.
1.43.7.112. 123teste
1.43.7.112. _este.`
var substitution = "$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}