$re = '/(?:\d*\.\d+|\d+)[MTBmtb]{0,1}\b/m';
$str = '1234b
1234B
.124b
0.123
1234bb
12345e';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);