package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\D+\s+\D+)(?:\s+\D+)*$`)
var str = `Color
Color 1
Color 2
Color 3
Age Range
Age Range Minimum
Age Range Maximum
Color
Color 1
Color 2
Color 3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}