package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\b(?<han>\p{Han}+)\b|\b(?<alpha>[a-zA-Z0-9{}']+)\b|(?<other>[^\p{Han}A-Za-z0-9\s]+)`)
var str = `Many cats{1}, several rats{2}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}