const regex = new RegExp('\\b(?<han>\\p{Han}+)\\b|\\b(?<alpha>[a-zA-Z0-9{}\\']+)\\b|(?<other>[^\\p{Han}A-Za-z0-9\\s]+)', 'sug')
const str = `Many cats{1}, several rats{2}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}