const regex = /(\[(\b(?i)sale\b|\b(?i)wtb\b|\b(?i)trade\b|\b(?i)go\b|\b(?i)iso\b)\].+\[[A-Z][A-Z]\].+\[.+\].+\[.+\])|(\[(\b(?i)sale\b|\b(?i)wtb\b|\b(?i)trade\b|\b(?i)go\b|\b(?i)iso\b)\]\[[A-Z][A-Z]\]\[.+\]\[.+\])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[(\\b(?i)sale\\b|\\b(?i)wtb\\b|\\b(?i)trade\\b|\\b(?i)go\\b|\\b(?i)iso\\b)\\].+\\[[A-Z][A-Z]\\].+\\[.+\\].+\\[.+\\])|(\\[(\\b(?i)sale\\b|\\b(?i)wtb\\b|\\b(?i)trade\\b|\\b(?i)go\\b|\\b(?i)iso\\b)\\]\\[[A-Z][A-Z]\\]\\[.+\\]\\[.+\\])', 'gm')
const str = `[sale][US][€12][sd]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}