$re = '/^\d{3,4}$/m';
$str = '025
9876
98
98765
000
000
02a
2a2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);