const regex = /((\d{1,2}:)?[0-5]?\d:[0-5]?\d)((\s|\'|\||-|,|(PM|AM))*)(((3[01]|[12][0-9]|0[1-9]|[1-9])|([0-9]{4}))(\/|\-|\|)(1[0-2]|0[1-9]|[1-9])(\/|\-)([0-9]{4}|(3[01]|[12][0-9]|0[1-9]))?)|((((3[01]|[12][0-9]|0[1-9]|[1-9])|([0-9]{4}))(\/|\-|\|)(1[0-2]|0[1-9]|[1-9]|\w{3})(\/|\-)([0-9]{1,4}|(3[01]|[12][0-9]|0[1-9])))(((\s|\'|\||-|,)*)((\d{1,2}:)?[0-5]?\d:[0-5]?\d))?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\d{1,2}:)?[0-5]?\\d:[0-5]?\\d)((\\s|\\\'|\\||-|,|(PM|AM))*)(((3[01]|[12][0-9]|0[1-9]|[1-9])|([0-9]{4}))(\\\/|\\-|\\|)(1[0-2]|0[1-9]|[1-9])(\\\/|\\-)([0-9]{4}|(3[01]|[12][0-9]|0[1-9]))?)|((((3[01]|[12][0-9]|0[1-9]|[1-9])|([0-9]{4}))(\\\/|\\-|\\|)(1[0-2]|0[1-9]|[1-9]|\\w{3})(\\\/|\\-)([0-9]{1,4}|(3[01]|[12][0-9]|0[1-9])))(((\\s|\\\'|\\||-|,)*)((\\d{1,2}:)?[0-5]?\\d:[0-5]?\\d))?)', 'g')
const str = `6/4/16 Lorem ipsum
00:00 09/04/2020 Lorem ipsum
20:20 01/07/2019 Lorem ipsum
00:00:00 01/07/1000 Lorem ipsum
01:00:00 01/07/1000 Lorem ipsum
19:57' 6/4/2020 Lorem ipsum
10:18, 09/04/2020 Lorem ipsum
15:39 | 08/04/2020 Lorem ipsum
Lorem ipsum00:15:39 | 31/04/2020 Lorem ipsum
Lorem ipsum 8:17 5/4/2020 Lorem ipsum
Lorem ipsum | 09:59:00 09/04/2020 Lorem ipsum
20:38 PM 08/04/2020 Lorem ipsum
Lorem ipsum 00:00 09/04/2020
00:00 09/04/2020 Lorem ipsum
Lorem ipsum 00:00 09/04/2020 Lorem ipsum
20:00 09/04/2020
Lorem ipsum 20:00 09/04/2020
20:00 09/04/2020 Lorem ipsum
Lorem ipsum 20:00 09/04/2020 Lorem ipsum
00:00 09-04-2020
Lorem ipsum 00:00 09-04-2020
00:00 09-04-2020 Lorem ipsum
Lorem ipsum 00:00 09-04-2020 Lorem ipsum
00:34 | 23/03/1984
Lorem ipsum 00:34 | 23/03/1984
00:34 | 23/03/1984 Lorem ipsum
Lorem ipsum 00:34 | 23/03/1984 Lorem ipsum
00:34 | 23-03-1984
Lorem ipsum 00:34 | 23-03-1984
00:34 | 23-03-1984 Lorem ipsum
Lorem ipsum 00:34 | 23-03-1984 Lorem ipsum
00:34 - 23-03-1984
Lorem ipsum 00:34 - 23-03-1984
00:34 - 23-03-1984 Lorem ipsum
Lorem ipsum 00:34 - 23-03-1984 Lorem ipsum
Lorem ipsum 00:34 - 23/03/1984
00:34 - 23/03/1984 Lorem ipsum
Lorem ipsum 00:34 - 23/03/1984 Lorem ipsum
Lorem ipsum 2020-04-20 00:00 Lorem ipsum
Lorem ipsum 23/03/1984 | 00:34 Lorem ipsum
Lorem ipsum 09/04/2020 00:00 Lorem ipsum
Lorem ipsum8/4/2020, 16:30Lorem ipsum
Lorem ipsum 08/4/2020, 16:30:00 Lorem ipsum
Lorem ipsum 06/02/2020 Lorem ipsum
Lorem ipsum 2014-04-01 12:00:00 Lorem ipsum
Lorem ipsum 09/04/2020 09:50 Lorem ipsum
Lorem ipsum 09/04/2020, 10:06 Lorem ipsum
Lorem ipsum, 09/04/2020 11:24 GMT +7
Lorem ipsum09/04/2020 9:50 Lorem ipsum
Lorem ipsum, 8/4/2020, 16:30
Lorem ipsum2014-mar-01 12:00:00 Lorem ipsum
Lorem ipsum 2020/08/08 | 12:12:33
Lorem ipsum 2020/08/08 ,12:12:33
Lorem ipsum 2020/08/08,12:12:33
Lorem ipsum 2020/08/08, 12:12:332324123 Lorem ipsum
Lorem ipsum 08/08/2020 15:31 Lorem ipsum
Lorem ipsum 17/01-2020 15:31 Lorem ipsum
Lorem ipsum 9/4/2020 - 12:07Lorem ipsum
Lorem ipsum 07/04/2020 - 08:11 Lorem ipsum
Lorem ipsum 09/04/2020 13:00 Lorem ipsum
Lorem ipsum 09/04/2020 13: Lorem ipsum
Lorem ipsum, 8/4/2020 22:53'(GMT+7)
6/4/16 Lorem ipsum 00:00 09/04/2020 Lorem ipsum 20:20 01/07/2019 Lorem ipsum 00:00:00 01/07/1000 Lorem ipsum 01:00:00 01/07/1000 Lorem ipsum 19:57' 6/4/2020 Lorem ipsum 10:18, 09/04/2020 Lorem ipsum 15:39 | 08/04/2020 Lorem ipsum
Lorem ipsum00:15:39 | 31/04/2020 Lorem ipsum Lorem ipsum 8:17 5/4/2020 Lorem ipsum Lorem ipsum | 09:59:00 09/04/2020 Lorem ipsum 20:38 PM 08/04/2020 Lorem ipsum Lorem ipsum 00:00 09/04/2020 lorem 00:00 09/04/2020 Lorem ipsum Lorem ipsum 00:00 09/04/2020 Lorem ipsum 20:00 09/04/2020 Lorem ipsum 20:00 09/04/2020 20:00 09/04/2020 Lorem ipsumLorem ipsum 20:00 09/04/2020 Lorem ipsum 00:00 09-04-2020 Lorem ipsum 00:00 09-04-2020 00:00 09-04-2020 Lorem ipsum Lorem ipsum 00:00 09-04-2020 Lorem ipsum 00:34 | 23/03/1984 Lorem ipsum 00:34 | 23/03/1984 00:34 | 23/03/1984 Lorem ipsum Lorem ipsum 00:34 | 23/03/1984 Lorem ipsum 00:34 | 23-03-1984 Lorem ipsum 00:34 | 23-03-1984 00:34 | 23-03-1984 Lorem ipsum Lorem ipsum 00:34 | 23-03-1984 Lorem ipsum00:34 - 23-03-1918Lorem ipsum 00:34 - 23-03-198400:34 - 23-03-1984 Lorem ipsum Lorem ipsum 00:34 - 23-03-1984 Lorem ipsumLorem ipsum 00:34 - 23/03/1984Lorem 00:34 - 23/03/1984 Lorem ipsum Lorem ipsum 00:34 - 23/03/1984 Lorem ipsum Lorem ipsum 2020-04-20 00:00 Lorem ipsum Lorem ipsum 23/03/1984 | 00:34 Lorem ipsum Lorem ipsum 09/04/2020 00:00 Lorem ipsum Lorem ipsum8/4/2020, 16:30Lorem ipsum Lorem ipsum 08/4/2020, 16:30:00 Lorem ipsum Lorem ipsum 06/02/2020 Lorem ipsum Lorem ipsum 2014-04-01 12:00:00 Lorem ipsum Lorem ipsum 09/04/2020 09:50 Lorem ipsum Lorem ipsum 09/04/2020, 10:06 Lorem ipsum Lorem ipsum, 09/04/2020 11:24 GMT +7 Lorem ipsum09/04/2020 9:50 Lorem ipsum Lorem ipsum, 8/4/2020, 16:30 Lorem ipsum2014-mar-01 12:00:00 Lorem ipsum Lorem ipsum 2020/08/08 | 12:12:33 Lorem ipsum 2020/08/08 ,12:12:33 Lorem ipsum 2020/08/08,12:12:33Lorem ipsum 2020/08/08, 12:12:332324123 Lorem ipsum Lorem ipsum 08/08/2020 15:31 Lorem ipsum Lorem ipsum 17/01-2020 15:31 Lorem ipsum Lorem ipsum 9/4/2020 - 12:07Lorem ipsum Lorem ipsum 07/04/2020 - 08:11 Lorem ipsum Lorem ipsum 09/04/2020 13:00 Lorem ipsum Lorem ipsum 09/04/2020 13: Lorem ipsum Lorem ipsum, 8/4/2020 22:53'(GMT+7)
Lorem ipsum, 09/04/2020 11:24 GMT +7 // mising GMT
09 tháng 04 năm 2020 09:11 GMT+7 // missing`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}