using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/s3.amazonaws.com\/(.?[^\/]*)\/(.*)";
string substitution = @"[\1] | [\2]";
string input = @"https://s3.amazonaws.com/jge-catalog-lake/guanaTest/Pet_Resource_Template.gdb.zip
https://s3.amazonaws.com/jge-data-platform-primary-automation-prod/DKU_TSHIRTS/orders_copy/out-s0.csv.gz
https://s3.amazonaws.com/jge-data-platform-primary-automation-prod/Approved_Data/Pet_Sed_Thick/Pet_Sediment_Thickness_Through_Time_P2V2_Resampled.tif.zip
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}