# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\w+ ){0,5}\w+@\w+\.(?:com|gov|edu|org)"
test_str = ("please send your resumes to adsf@dsf.com apply now!\n"
"asdfa@asdf.com/adsf asdf\n"
"visit us at sfds@adfa\n"
"apply now\n"
"follow us on asdf@asdf.gov\n"
"asdfa.gov\n"
".com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.