# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bu1[[:alnum:]]{7}[[:alpha:]]\b"
test_str = ("6x7 456 78993 45528 8382 837372 82 128 8282 82 828282 28 8282635372892 838 \n"
"Lorem ipsum dolor 335-5555555 sit amet, consectetur adipisci5555555555 elit, sed eiusmod tempor incidunt ut labore et dolore magna aliqua.\n\n"
"Ut enim ad minim veniam, quis nostrum exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur. 3835555555 Quis aute iure reprehenderit in voluptate 555/555555velit esse cillum dolore eu fugiat nulla pariatur. 43434734 343 3 464 56 5 65 6 5 757 676\n\n"
"Excepteur sint obcaecat cupiditat U1B538525Nnon R proident, sunt in culpa qui officia deserunt mollit anim id est laborum. Lorem ipsum dolor sit amet, consec 234 546 367 2789 tetur adipisci elit,347/5555555 sed eiusm 565437 od tempor incidunt ut labore etu1e481477k dolore magna aliqua. Ut enim ad minim u1e481477p\n\n\n\n"
"Ut enim ad minim 555-555555veniam, quis ru nostrum exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi u1e481477k consequatur. Quis aute iure r328 5555555 eprehenderit in volup6767676767 6767676767tate 555 555555velit esse cillum dolore eu fugiat nulla pariatur. SHA2: 4300f88fd8b98288247210a57u1e481477kdab09568d85e3d28df822265329b0\n\n"
"Excepteur sint obcae67676767676767676cat rs cupidita34567893 t non proident, sunt in culpa qui officia deserunt mollit anim id est laborum. 388.555555 Lorem rSsndr74d04a271u ipsum dolor sit amet, consectetur adipisci elit, sed eiusmod tempor incidunt ut labore et dolore magna a6767676767 32252525 353535 5353535liqua. Ut enim ad minim")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.