re = /Ordernr.*[\r\n]+(.*)/
str = '21Sid1
Ordernr Skip everything upto new line
E17222
By
Seller'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end