#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:[ab]*c){1,2}[ab]*$)(?=(?:[bc]*a){3})(?:[ac]*b){3}[abc]*$"
Local $sString = "aaabbb" & @CRLF & _
"ababab" & @CRLF & _
"aaabbbccc" & @CRLF & _
"abcabcabc" & @CRLF & _
"ababcabcc" & @CRLF & _
"" & @CRLF & _
"aaabbbc" & @CRLF & _
"aabbb" & @CRLF & _
"abbccc" & @CRLF & _
"abcabca" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")