package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-([^-\n]+)(?:-|$)`)
var str = `tumPar-PredCorr
lung-Med-Pred
liver-t1flair-FromMed
kidney-t1ce-Pred
tumMed-Pred`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}