using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<([a-z]+)>(.*)<\/\1>)|((?:(?!<[a-z]+>.*<\/[a-z]+>).)+)";
string input = @"This is <yellow>message</yellow> that needs <green>to be formatted</green>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}