using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b([0-9]{10}|[0-9\s]{12})\b)";
string input = @"KINDLY AUTH FOR FUNDS
ACC 1469007967 (Number needs to be extracted)
KINDLY AUTH FOR FUNDS
ACC 146900796723423 **(Want to ignore this number)**
ACC NUMBER -1186 057 378 **(the number after - sign needs to be extracted)**
**1162792833** CHQ:104-R8856.00 AND (The number in ** needs to be extracted)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}