# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\b([0-9]{10}|[0-9\s]{12})\b)"
test_str = ("KINDLY AUTH FOR FUNDS\n"
"ACC 1469007967 (Number needs to be extracted)\n\n"
"KINDLY AUTH FOR FUNDS\n"
"ACC 146900796723423 **(Want to ignore this number)**\n\n"
"ACC NUMBER -1186 057 378 **(the number after - sign needs to be extracted)**\n\n"
"**1162792833** CHQ:104-R8856.00 AND (The number in ** needs to be extracted)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.