$re = '/(?<=(?:as|AS))\s+[^\s.,\(\)\-=]+(?:\s*)|[^\s.,\(\)\-=][^\s.,\(\)\-=]+\s*(?==)/m';
$str = 'anp_t3.PREIS AS ANP_LEIH_PREIS, anp_t3.WAEHRUNG as ANP_LEIH_WAEHRUNG, anp_t3.BIS as ANP_LEIH_BIS, TESTWERT = t1.VALUE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);