package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\^{1,2})([0-7]{1,2})([a-zA-Z]+)`)
var str = `^1Piros^^2Zold^^06Sarga^3-=98`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}