const regex = /(.+?)[ ]+(\d+)[ ]*:[ ]*(\d+)[ ]+(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+?)[ ]+(\\d+)[ ]*:[ ]*(\\d+)[ ]+(.+)', 'gm')
const str = `My Team U19 14 : 1 Team A
Myeam 74 : 15 Team D U18
T 2 : 1 Team A
Meam 10 : 1 Tem A
Myam U20 4 : 10 Te A
MTeam 6 : 1 Tea A
My 4 : 1 Team A
Mybeam U16 45 : 1 Tbgm A U16
M 12 : 1 Tm A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}