package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.+) (.+) \[(.+)\] - (.+)`)
var str = `(17-03-2015 15:00:00) pbphl0w [niels] - (testing) dit is een bericht
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}