# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=~\/|\.\/|\..\/|\/|file:\/\/\/|\w)[\w\-\._\(\)\[\] ]+$"
test_str = ("file:///Users/john.smith/Projects/joehall-logo-256x256.png\n"
"/Users/john.smith/Downloads/favicon_package_v0.16 (2).zip\n"
"/Users/john.smith/Downloads/favicon_package_v0.16 (2)/android-chrome-512x512.png\n"
"~/Downloads/favicon_package_v0.16 (2)/android-chrome-512x512.png\n"
"../../assets/android-chrome-512x512.png\n"
"./android-chrome-512x512.png\n"
"android-chrome-512x512.png")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.