re = /(?=~\/|\.\/|\..\/|\/|file:\/\/\/|\w)[\w\-\._\(\)\[\] ]+$/im
str = 'file:///Users/john.smith/Projects/joehall-logo-256x256.png
/Users/john.smith/Downloads/favicon_package_v0.16 (2).zip
/Users/john.smith/Downloads/favicon_package_v0.16 (2)/android-chrome-512x512.png
~/Downloads/favicon_package_v0.16 (2)/android-chrome-512x512.png
../../assets/android-chrome-512x512.png
./android-chrome-512x512.png
android-chrome-512x512.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end