import re
regex = re.compile((r"/\*\n?\r?\n"
r"(?: \* ©20\d{2}.*\n?\r?)\n"
r"(?: \*(?:.*\n?\r?))+\n"
r" \*/"), flags=re.MULTILINE)
test_str = ("/*\n"
" * ©2012 <!-- start slipsum code -->\n"
" *\n"
" * Do you see any Teletubbies in here? Do you see a slender plastic tag clipped to my shirt with my name printed on it? Do you see a little Asian child with a blank expression on his face\n"
" * sitting outside on a mechanical helicopter that shakes when you put quarters in it? No? Well, that's what you see at a toy store. And you must think you're in a toy store, because you're here shopping for an infant named Jeb.\n"
" * <!-- end slipsum code -->\n"
" */\n\n"
"/*\n"
" * ©2021 <!-- start slipsum code -->\n"
" *\n"
" * Do you see any Teletubbies in here? Do you see a slender plastic tag clipped to my shirt with my name printed on it? Do you see a little Asian child with a blank expression on his face\n"
" * sitting outside on a mechanical helicopter that shakes when you put quarters in it? No? Well, that's what you see at a toy store. And you must think you're in a toy store, because you're here shopping for an infant named Jeb.\n"
" * <!-- end slipsum code -->\n"
" */")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")